If you’re running a version of Android older than 4.3, the latest SurveyCTO Collect app will not work on your device. You can download an older version below, which will work on Android versions as old as 2.3 (Gingerbread, released December 2010). Keep in mind, this is an old version of SurveyCTO Collect so any features from versions after 2.41 will not be available. You can find out what features may be missing on our release notes page. 

Close Menu